vom Client mit CMD.exe auf FTP Server zugreifen?

Flo
Hi,

habe einen W2K Client (192.168.1.1) und einen Win98 Server (192.168.1.2) auf dem Jana läuft. Jana habe ich an die IP 192.168.1.2 gebunden und dort proxy server, http server, ftp server, ftp gateway und socks 4/5 aktiviert. Vom Client kann ich per FTP Programm(Leech FTP) wunderbar auf FTP Server im INet zugreifen, nur mit Kommandozeilenprogramm funktioniert es nicht. Vom Server direkt geht es. Muß ich da noch in Jana irgendwo was freischalten?

flo
Waldo
Hallo,
das ftp.exe Programm von Windows ist nicht in der Lage, über einen Proxy-Server auf das Internet zu gehen. Dafür braucht man entweder einen ftp-Client wie WS-FTP oder eine Utility, die die Zugriffe von ftp.exe umleitet.

Gruss Waldo
Thrombo
Hallo,

Es gibt 3 Möglichkeiten den FTP Client von Microsoft via Jana zu nutzen (getestet mit FTP.EXE WinNT 4.0).

1. Interaktiver Modus

a) Start des FTP Clients (FTP.EXE ohne Parameter). Man sieht den FTP prompt:

Ftp>

b) Eingabe des FTP Befehls gefolgt von Entertaste

open jana_ipadresse port_ftpgateway

Beispiel Bildschirmausgabe:
Ftp> open 172.24.1.5 2121
Verbunden zu 172.24.1.5.
220 FTP Gateway at Jana Server ready
Benutzer (172.24.1.5: (none)):


c) Der FTP Client wartet jetzt auf die Eingabe des Benutzernamens. Eingabe am Prompt:
anonymous@ftp_servername gefolgt von Entertaste. FTP Client sendet die Daten an den
FTP Gateway von Jana. Jana baut die Verbindung zum FTP Server auf und benutzt anonymous
als Username.

Beispiel Bildschirmausgabe für ftp.microsoft.com:
Benutzer (172.24.1.5: (none)):
anonymous@ftp.microsoft.com


d) Wenn der FTP Server den Benutzernamen akzeptiert sendet er einen 331 Message und erwartet
die Eingabe des Passworts.

Beispiel Bildschirmausgabe für ftp.microsoft.com:
331 Anonymous access allowed, send identity (e-mail name) as password.
Kennwort:


e) Eingabe des Passwortes (Mailadresse für anonymen Zugriff) gefolgt von Entertaste.

Beispiel Bildschirmausgabe für ftp.microsoft.com:
331 Anonymous access allowed, send identity (e-mail name) as password.
Kennwort:
230-This is FTP.MICROSOFT.COM Please see the dirmap.txt
230-file for more information.
230 Anonymous user logged in.
Ftp>


Jetzt kann man die üblichen Befehle verwendet um das Verzeichnis zu wechseln, Dateien zu holen oder zu senden.


2. Kommandomodus

a) Man muss eine Textdatei anlegen in die alle Befehle geschrieben werden die vom FTP Client automatisch
ausgeführt werden sollen.

Beispiel des Inhaltes einer Datei MICROSOFT.TXT.

open 172.24.1.5 2121
anonymous@ftp.microsoft.com
kk@gg.de
ls
quit


Die Verbindung zum FTP Server ftp.microsoft.com wird mit der Benutzerkennung anonymous aufgebaut. Das Passwort als Mailadresse übermittelt. Der Verzeichnisinhalt wird angezeigt (ls) und die Verbindung beendet (quit).
Natürlich kann man weitere Befehle einfügen wie Übertragungsmodus wechseln (type binary), Dateien holen (get ....) usw.

b) Start des FTP Client mit Parameter für den Kommandomodus.

FTP -s:name_befehlsdatei

z.B.:
FTP -s:MICROSOFT.TXT

Die Befehle in der Datei werden dann abgearbeitet.


3. Nutzung des FTP Clients über einen SOCKS-Client.

Mittels eines SOCKS Clients kann der Microsoft FTP Befehl genauso wie im Lokalem Netz benutzt werden.
Der SOCKS Client von Hummingbird erlaubt dabei auch aktive FTP Verbindungen. Download der Kurzdoku über
http://www.janaserver.de -> Nützliches und Extras. In der Kurzdoku steht auch der Downloadlink zur
Version 7.0 (7.1 ist bugy).


Ein freeware FTP Client für 32-bit Windows der auch FTP Operationen via Kommandozeile
ausführen kann ist unter http://www.ncftp.com verfügbar. Proxy und Firewalls werden
unterstützt, ebenso rekursives kopieren von FTP Verzeichnisbäumen usw.


MfG

Thrombo
Waldo
Hallo Thrombo,
hast recht, geht wie geschmiert!

Danke!

Gruss Waldo
Thrombo
Hallo Waldo,

welche der 3 Varianten hast Du getestet ?

Gruss

Thrombo
Waldo
Soory!
Mit ftp.exe hab ich den Kommandomodus ausprobiert. Einfach interaktiv reingetippt.
Die Dateiform (ftp -s ...) habe ich nicht probiert, sie läuft bei mir seit einiger Zeit (mangels Kenntnis nicht über Jana sondern direkt am Server)!

Kann man die Zugangsmodalitäten über das FTP-Gateway irgendwo nachlesen? Hätte es für mein Autoupdate von F-Prot über ftp brauchen können.

Gruss Waldo
Flo
Hi,

danke für die Antworten.
Bei mir ist aber auch das Problem, daß immer unbekannter Host angezeigt wird, Es wird nicht mal ein Versuch unternommen eine Verbindung aufzubauen.
Den Host gibt es aber, da es ja in mit einem FTP Programm vom gleichen Rechner aus klappt.

Flo
Waldo
Hallo flo,
wenn Du mit ftp.exe von MS arbeitest, meldest Du Dich zuerst am FTP-Gateway vom Jana Server an:

c:\>ftp
ftp>open 192.168.1.2 2121

Darauf müsste sich der Jana Server melden und einen Benutzernamen abfragen.
Das müsste aber auf jeden Fall tun. Hier wird nichts anderes gemacht als es jedes andere FTP Programm implizit macht.
Kommt hier schon ein Fehler, stimmt mit dem Netzzugriff was nicht!! Firewall?
Danach kann der Zugriff, wie Thrombo unter 1.c) und 1.d) beschreibt, auf den FTP-Server im Internet gamacht werden.

Gruss Waldo
Waldo
Hallo,
checke doch bitte auch die Bindung vom FTP-Gateway im Jana Server an die Netzwerkkarte 192.168.1.2.

Gruss Waldo
Thrombo
Hallo Waldo,

In der Onlinehilfe zu WinNT Server heißt es beim Befehl open lapidar:

Zitat:
Ftp: open

Stellt eine Verbindung zum angegebenen FTP-Server her.
open Host [Anschluß]

Parameter

Host
Gibt den Remote-Computer an, zu dem eine Verbindung hergestellt werden soll. Die Angabe von Host kann als IP-Adresse oder als Host-Name (eine DNS- oder HOST-Datei muß vorhanden sein) erfolgen. Falls die automatische Anmeldung aktiviert ist (Standardeinstellung), versucht FTP, den Benutzer am FTP-Server anzumelden (siehe auch Ftp-n).

Anschluß
Gibt eine Anschlußnummer für den Verbindungsaufbau zum FTP-Server an.


Mehr gibt es nicht.

Ein kleines Beispiel für den Inhalt einer FTP Befehlsdatei, mit der das aktuelle Virendefinitionsarchiv für die Backup Software BackupExec von Veritas geholt wird. Der Name ändert sich laufend, nur die Endung bleibt gleich. Deshalb mit Prompt den Interaktiven Modus abschalten und Datei mit mget holen.

VERIVIR.TXT :

open 172.24.1.5 2121
anonymous@ftp.support.veritas.com
kk@gg.de
type binary
lcd C:\copy
cd /pub/support/products/NAI/
prompt
mget *.cab
quit


Befehl:

ftp -s:VERIVIR.TXT

Das wars !!!

ftp hat noch einen Bug ! GET Befehle länger als 20 Zeichen schlagen fehl. Abhilfe, vorher mit cd ins Verzeichnis wechseln. Siehe dazu auch:

http://support.microsoft.com/default.asp...b;en-us;Q279170

MfG

Thrombo
Waldo
Hallo Thrombo,
mein Batch und FTP-Scriptfile tut seinen Dienst, aber eben bisher nicht über das Gateway.

Mir war die Modalität, die das Jana Gateway voraussetzt nicht klar, da ich dazu keine Doku habe.

Gruss Waldo

FTP-Script:
open
ftp.frisk.is
anonymous
...Email...
cd pub
dir
binary
get fp-def.zip
get macrdef2.zip
quit
Thrombo
Waldo,
dann ändere doch mal auf:

open jana_ip 2121
anonymous@ftp.frisk.is
...Email...
cd pub
dir
binary
get fp-def.zip
get macrdef2.zip
quit


Bei mir funktionierts großes Grinsen

Gruss

Thrombo
Flo
Hi,

jetzt hats funktioniert, (hab aber nur 1. probiert -erstmal)danke nochmal.

Flo
danny123
Hallo,

bei mir ist in Jana die Benutzerverwaltung aktiv, d.h. wenn ich über die ftp.exe auf Jana zugreife, muss ich zuerst Benutzer und Passwort für Jana angeben. Nur wie komme ich dann auf den externen Server?
Beispiel: Jana IP 192.168.97.1
Benutzer bei Jana: abcd
Passwort bei Jana: 1234

Jetzt kann ich zwar eingeben:
ftp
open 192.168.97.1 2121
abcd
1234

Dann bin ich aber erst bei jana angemeldet und müsste nun nochmals den open-Befehl für den externen Server verwenden, z.B.
open 202.114.2.6

Das funktioniert aber nicht, da Jana meldet: Die Verbindung zu 192.168.97.1 besteht bereits bitte Verbindung zuerst beenden.

Gibt es dafür eine Lösung ohne eine anderen ftp-client zu verwenden, weiss jemand Rat?

Danke
danny
1970
Hallo,

Dein Versuch ist nur in der ersten Hälfte richtig. Es muß heißen

ftp
open 192.168.97.1 2121
abcd@internetadresse.de
1234

Gruß

Erik
René
Hallo Erik,

wenn ich "danny" richtig verstanden habe ist abcd und 1234 der login für das Jana FTP-Gateway. Jetzt fehlt noch der Login für den eigendlichen FTP-Server.
1970
Hallo,

René hat Recht, habe das mit der Benutzerverwaltung überlesen. Habe selbst ein wenig probiert, es gibt scheinbar keine Möglichkeit der ftp.exe die Zugangsdaten für den Gateway mitzugeben.

Du wirst es ohne einen anderen FTP-Client nicht schaffen oder Du mußt den FTP-Gateway für alle Benutzer freischalten.

Gruß

Erik
mikew
Ich stell hier mal kommentarlos die richtige Sequenz rein:


open <ftpGateway> <ftpGatewayPort>
<localUser>
<localPass>
quote open <externServer>
quote user <externUser>
quote pass <externPass>
<dann weitere FTP-Befehle ohne "quote">


Insofern ist 1970s Aussage, es ginge nicht mit ftp.exe (Am Rande: cmd.exe hat überhaupt nichts mit ftp.exe zu tun!) falsch.




Beispiel:

> ftp

open jana.mydomain.local 2121
sepperl
a4rgh57!!#1,n
quote open ftp.f-prot.com
quote user anonymous
quote pass sepperl@sepperlathome.de
cd pub
dir
danny123
Vielen Dank Leute für eure Antworten, besonders an dich mikew. Es funktioniert nun wunderbar. Danke nochmal. fröhlich großes Grinsen